Autor Thema: Passwort bei der Schnellanmeldung falsch  (Gelesen 4828 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

darkweasel

  • Obermeister
  • *
  • Beiträge: 3347
  • Kompliziertdenker
Passwort bei der Schnellanmeldung falsch
« am: 03. Juli 2014, 13:59:18 »
Ich habe jetzt schon wiederholt das Problem, dass, wenn ich versuche, mich mittels der Anmeldemaske, die sich in ausgeloggtem Zustand oben auf jeder Seite befindet, einzuloggen, die Meldung kommt, dass das Passwort falsch ist. Wenn ich genau dasselbe Passwort dann auf ?action=login eingebe, funktioniert es. Es scheint bei der Schnellanmeldung nie, auf ?action=login aber immer zu funktionieren, und ich kann mir ehrlich gesagt nicht vorstellen, dass ich mich zufällig immer genau bei der einen Maske vertippe und bei der anderen nicht. Kann das jemand reproduzieren?

Edit: Ok, ich muss die Problembeschreibung abändern. Es scheint nicht mit der einen und der anderen Anmeldemaske zu tun zu haben, sondern damit, ob es einen PHPSESSID=-Parameter in der URL gibt. Wenn es einen gibt, schlägt die Anmeldung fehl.

95B

  • Verkehrsstadtrat
  • **
  • Beiträge: 33585
  • Anti-Klumpert-Beauftragter
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #1 am: 03. Juli 2014, 14:06:52 »
Ich habe jetzt schon wiederholt das Problem, dass, wenn ich versuche, mich mittels der Anmeldemaske, die sich in ausgeloggtem Zustand oben auf jeder Seite befindet, einzuloggen, die Meldung kommt, dass das Passwort falsch ist. Wenn ich genau dasselbe Passwort dann auf ?action=login eingebe, funktioniert es. Es scheint bei der Schnellanmeldung nie, auf ?action=login aber immer zu funktionieren, und ich kann mir ehrlich gesagt nicht vorstellen, dass ich mich zufällig immer genau bei der einen Maske vertippe und bei der anderen nicht. Kann das jemand reproduzieren?

Probier es mit Copy & Paste, um Tippfehler auszuschließen.
Es ist nichts so fein gesponnen, es kommt doch ans Licht der Sonnen!
... brrrr, Klumpert!

darkweasel

  • Obermeister
  • *
  • Beiträge: 3347
  • Kompliziertdenker
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #2 am: 03. Juli 2014, 14:09:21 »
Ich habe jetzt schon wiederholt das Problem, dass, wenn ich versuche, mich mittels der Anmeldemaske, die sich in ausgeloggtem Zustand oben auf jeder Seite befindet, einzuloggen, die Meldung kommt, dass das Passwort falsch ist. Wenn ich genau dasselbe Passwort dann auf ?action=login eingebe, funktioniert es. Es scheint bei der Schnellanmeldung nie, auf ?action=login aber immer zu funktionieren, und ich kann mir ehrlich gesagt nicht vorstellen, dass ich mich zufällig immer genau bei der einen Maske vertippe und bei der anderen nicht. Kann das jemand reproduzieren?

Probier es mit Copy & Paste, um Tippfehler auszuschließen.
Habe ich ausprobiert. Das Problem (dessen Beschreibung ich gerade abgeändert habe) ist weiterhin da: wenn ich dasselbe Passwort in eine Maske mit PHPSESSID einfüge, funktioniert es nicht, in eine ohne PHPSESSID funktioniert es.

Edit: Es dürfte ein weiterreichender SMF-Fehler sein. Im Autobusforum ist es auch reproduzierbar.

tram

  • Administrator
  • Zugführer
  • *****
  • Beiträge: 529
    • Tramwayforum
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #3 am: 03. Juli 2014, 21:22:22 »
Eigentlich sollte in der URL überhaupt keine Session-ID vorhanden sein, damit lassen sich nämlich prima Sessions anderer User hijacken, wenn sie unabsichtlich so einen Link setzen.

darkweasel

  • Obermeister
  • *
  • Beiträge: 3347
  • Kompliziertdenker
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #4 am: 03. Juli 2014, 21:47:31 »
Eigentlich sollte in der URL überhaupt keine Session-ID vorhanden sein, damit lassen sich nämlich prima Sessions anderer User hijacken, wenn sie unabsichtlich so einen Link setzen.
Ich bekomme solche URLs, wenn ich im privaten Modus im Chrome oder Firefox hierher komme.

tram

  • Administrator
  • Zugführer
  • *****
  • Beiträge: 529
    • Tramwayforum
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #5 am: 03. Juli 2014, 22:23:35 »
Interessant, Safari verhält sich ganz normal.

phil1296

  • Fahrer
  • ***
  • Beiträge: 489
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #6 am: 03. Juli 2014, 23:27:45 »
Ich habe genau dasselbe Problem, verwende Chrome (verschiedene Versionen) klappt aber nie :'(
Lieber 67er nach Oberlaa, ich werde dich vermissen!

Petersil

  • Fahrer
  • ***
  • Beiträge: 450
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #7 am: 04. Juli 2014, 01:50:13 »
Ich kann den Fehler bestätigen und hatte den unter Firefox öfters. Ich habe es allerdings immer auf meine Unfähigkeit, das deutsche Tastaturlayout auszuwählen, geschoben.

coolharry

  • Referatsleiter
  • *
  • Beiträge: 5550
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #8 am: 04. Juli 2014, 09:00:19 »
Unter IE11 funzt alles wie es soll. Ja ich weiß Mircosoft ist bähh.
Weil ein menschlicher Hühnerstall nicht der Weisheit letzter Schluß sein kann.

egilmar

  • Fahrgast
  • *
  • Beiträge: 38
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #9 am: 06. August 2014, 13:55:10 »
Ich hatte/habe das Problem auch manchmal (FF). Das PW ist aber in einem PW Manager gespeichert, also kann ich Tippfehler ausschließen! Wenn ich dann einfach nochmal auf [Einloggen] klicke (ohne etwas zu verändern) funktioniert der Login. Ich werde einmal versuchen den Fehler zu reproduzieren.

B1.702

  • Gast
Re: Passwort bei der Schnellanmeldung falsch
« Antwort #10 am: 07. August 2014, 13:33:10 »
Unter IE11 funzt alles wie es soll. Ja ich weiß Mircosoft ist bähh.

Man kann Websites auch so schreiben, dass sie mit fehlerhaften Browsern funktionieren. Dann gehen sie halt mit standardkonformen nicht mehr. ;-)